2. Upgrading From LOCKSS 2.0-alpha4

Note

This chapter describes how to upgrade an existing LOCKSS 2.0-alpha4 system to 2.0-alpha5.

If you are installing the LOCKSS system for the first time, go to Installing the LOCKSS System instead.

Tip

Before you begin the upgrade, we strongly recommend you first bring your operating system up to date by applying security updates and upgrading installed packages. Ask your system administrator or see Operating System Updates in the appendix.

2.1. Stop LOCKSS 2.0-alpha4

The first step is to stop the LOCKSS 2.0-alpha4 system.

Log in as the lockss user and run the following command in the lockss-installer directory:

scripts/stop-lockss

2.2. Update the LOCKSS Installer

The official way to download the LOCKSS Installer is now through the LOCKSS Downloader, rather than cloning the LOCKSS Installer as a Git project as in previous releases. However, advanced users may continue to use git if they wish (see Downloading the LOCKSS Installer using git for instructions).

Move the existing 2.0-alpha4 LOCKSS Installer out-of-the-way:

mv lockss-installer lockss-installer.alpha4

Then follow the steps in Installing the LOCKSS System to download the 2.0-alpha5 version of the LOCKSS Installer, skipping over the earlier sections of the chapter that are not required in the context of an upgrade (e.g., Creating the lockss User).

2.3. Run the Upgrade Script

We have provided an upgrade script to upgrade on-disk structures. To run it, log in as the lockss user and run the following command in the lockss-installer directory:

scripts/upgrades/upgrade-alpha4-to-alpha5

2.4. Re-run the Configure Script

Copy the existing LOCKSS system configuration into the new 2.0-alpha5 environment:

cp lockss-installer.alpha4/config/system.cfg lockss-installer/config/system.cfg

Then follow the instructions in Configuring the LOCKSS System to ensure all existing configuration parameters are still correct and to configure any new parameters.

2.5. Next Steps

Follow the instructions in Running the LOCKSS System to start your LOCKSS 2.0-alpha5 instance.

Note

The first time 2.0-alpha5 is started after an upgrade from 2.0-alpha4, it may take several minutes before the system becomes available, while it re-indexes all previously archived content.